Some Work Management and iPaaS Pages Unresponsive

Incident Report for TeamDynamix

Resolved

The U.S. tenant of iPaaS/CAI had a brief moment of UI unavailability, and flows responding with 502 bad gateway error codes between 12:37PM ET and 12:48PM ET. This issue is now resolved.
Posted Jan 14, 2026 - 14:24 EST

Update

We are currently investigating an issue that caused some Work Management pages and iPaaS to be unresponsive between 12:37PM ET to 12:48PM ET.
Posted Jan 14, 2026 - 13:04 EST

Monitoring

We are currently investigating an issue that caused iPaaS to be unresponsive between 12:37PM ET to 12:48PM ET.
Posted Jan 14, 2026 - 12:57 EST
This incident affected: East US - Work Management (Asset Discovery, Integrations (3rd Party), Mobile App, Sandbox) and East US - iPaaS (Web Interface).