Backend Services Offline While 12.1 Cutover Completes

Incident Report for TeamDynamix

Resolved

The 12.1 cutover is complete and backend services are now running again.
Posted Nov 08, 2025 - 08:09 EST

Investigating

The 12.1 production upgrade is live for the majority of the system. We are still processing a cutover which impacts the following services: Item Alerts, KB Article Review Reminders, Project Health Updates, Report Delivery, RSS Feeds, Source Control Events, Ticket SLAs and Ticket Workflow Web Service Steps. We will continue to provide updates as the cutover progresses.
Posted Nov 08, 2025 - 04:08 EST
This incident affected: East US - Work Management (AI Services, Scheduled Event Processing) and Canada - Work Management (AI Services, Scheduled Event Processing).