Investigating Performance Degradation

Incident Report for TeamDynamix

Resolved

Incident is resolved. We are continuing to investigate the root cause and will provide that when it is available.
Posted Nov 06, 2025 - 14:50 EST

Monitoring

TeamDynamix performance has returned to normal levels as of 1:51 eastern. It began around 1:31 eastern. We are investigating the root cause and will post that here when available.
Posted Nov 06, 2025 - 14:30 EST

Investigating

We are currently investigating reports of performance degradation.
Posted Nov 06, 2025 - 13:47 EST
This incident affected: East US - iPaaS (Web Interface) and East US - Work Management (Web Interface).