Investigating Reports of Email Monitor & Attachment Errors

Incident Report for TeamDynamix

Resolved

We identified and addressed a capacity issue impacting the file system by scaling the affected environment. Email monitoring and attachment uploads are now functioning normally, and all services have been restored. Thank you for your patience while we worked to resolve this issue.
Posted Sep 18, 2026 - 08:51 EDT

Monitoring

We identified a capacity issue impacting the file system and successfully scaled the environment to address it. Email monitoring and attachment uploads are now functioning as expected.
Posted Sep 17, 2026 - 22:26 EDT

Investigating

We are currently investigating reports of elevated email monitor errors and attachment upload failures within Work Management.
Posted Sep 17, 2026 - 22:13 EDT
This incident affected: East US - Work Management (Email, Web Interface).