TeamDynamix WorkManagement Integrations issues (Workaround Instructions in Message)

Incident Report for TeamDynamix

Monitoring

ACTION REQUIRED: As part of the 12.1 release, we performed a cutover to update all Microsoft Teams integrations. During this process, the update was inadvertently applied to all integration types, including:

- Bomgar
- Microsoft Teams
- Slack
- TeamDynamix iPaaS
- Microsoft Intune

This caused the settings for all integrations except Microsoft Teams to become corrupted. To restore full functionality, the settings for the following integrations will need to be re-enabled:

- Bomgar: https://solutions.teamdynamix.com/TDClient/1965/Portal/KB/ArticleDet?ID=9244
- Slack: https://solutions.teamdynamix.com/TDClient/1965/Portal/KB/ArticleDet?ID=115017
- TeamDynamix iPaaS: https://solutions.teamdynamix.com/TDClient/1965/Portal/KB/ArticleDet?ID=115872
- Microsoft Intune: https://solutions.teamdynamix.com/TDClient/1965/Portal/KB/ArticleDet?ID=161834

We apologize for the inconvenience. If you have trouble re-enabling any of the integrations, please reach out to our support team for further assistance: https://solutions.teamdynamix.com/TDClient/1965/Portal/Requests/ServiceDet?ID=2147
Posted Nov 08, 2025 - 10:26 EST

Update

WORKAROUND: To resolve the issue, locate the Customer ID and Secret in the AI and Automations (iPaaS) environment by going to the Administration Menu > Service Accounts and opening the service account used for your TeamDynamix environment. Account ID maps to Customer ID, and Primary Secret maps to Client Secret. Copy those values into TDAdmin > Organization Settings > TeamDynamix Automation Settings -> Integration Settings and hit save.
Posted Nov 08, 2025 - 08:37 EST

Update

We are continuing to work on a fix for this issue.
Posted Nov 08, 2025 - 08:09 EST

Identified

We have identified an issue with the linkage between Work Management and iPaaS that could cause issues with the ChatBot loading on Client Portal and the error message "A fatal error was encountered. Message: The Customer ID must be a valid GUID format. Please verify the Customer ID from your TeamDynamix Automation Platform settings." on iPaaS flow runs. We are working on a permanent fix for this issue. We have found that resaving the Integration Settings at TDAdmin -> Organization Setttings -> TeamDynamix Automation Settings -> Integration Settings is a viable workaround to restore service immediately.
Posted Nov 08, 2025 - 05:36 EST
This incident affects: East US - Work Management (AI Services, Integrations (3rd Party)) and Canada - Work Management (AI Services, Integrations (3rd Party)).