Investigating Performance Degradation

Incident Report for TeamDynamix

Resolved

We’ve resolved the issue that was causing degraded performance in TeamDynamix Work Management, and full service has now been restored. We appreciate your patience and understanding during this time.

Our team is continuing to investigate the root cause and will share additional details once the post-incident review is complete. We are also actively monitoring the system to ensure everything remains stable and continues to run smoothly.

Thank you for your continued support.
Posted Nov 10, 2025 - 16:31 EST

Update

We continue to work on the issue causing degraded performance in TeamDynamix Work Management. We sincerely apologize for the inconvenience and appreciate your patience. Our team is working around the clock to restore full service as quickly as possible. Once service is fully restored, we will share additional details regarding the root cause.
Posted Nov 10, 2025 - 15:12 EST

Update

We want to provide an update regarding the performance issues affecting our application.

As shared earlier, we deployed a fix intended to resolve the degradation. Unfortunately, the fix did not produce the expected improvements, and we are still seeing performance challenges.

Our team is actively investigating the issue with high priority. We are exploring additional solutions and working diligently to identify and address the root cause. We understand how critical our service is to your operations and deeply regret the inconvenience this is causing.

We will continue to keep you informed with regular updates and will notify you as soon as we have more information or a confirmed resolution. Once we restore service, we will provide additional information on root cause.
Posted Nov 10, 2025 - 12:58 EST

Monitoring

A fix has been deployed for Work Management performance degradation. Pages should begin to load. We are still actively monitoring and will continue to communicate updates.
Posted Nov 10, 2025 - 12:08 EST

Identified

Thank you for your continued patience.

We have identified the issue and are actively working to develop a fix for the Work Management performance degradation. We'll continue to provide updates as we know more about estimated resolution time.
Posted Nov 10, 2025 - 11:08 EST

Update

We are continuing to investigate this issue.
Posted Nov 10, 2025 - 09:50 EST

Investigating

We are currently investigating reports of performance degradations.
Posted Nov 10, 2025 - 09:41 EST
This incident affected: East US - Work Management (Web Interface).