Increased response times

Incident Report for TeamDynamix

Resolved

Hotfixes have been implemented to address elevated response times caused by processing the backend data for dashboard widgets. We have observed performance returned to normal levels as of about 11:20 AM ET.
Posted Nov 13, 2025 - 12:08 EST

Investigating

We have noticed instances of increased response times and are taking corrective efforts to reduce those to normal levels. We'll provide updates here as they are available.
Posted Nov 12, 2025 - 15:04 EST
This incident affected: East US - Work Management (Web Interface).